Metaphorical Dream

<   2009年 10月 ( 29 )   > この月の画像一覧

ESX4.0 VMWareFT

Overjoyedが好きなのはもちろんなんだけど、
今回はMan in the Mirrorで検証実施。

VMWareHAとVMWareFTの大きな違いは、
仮想マシンを再起動するか否か?ってところ。

んで、Man in the MirrorをMcastストリーム配信で
気持ち良く聴きたいので、VMWareFTを選択。

いざ!検証実施。
e0113173_1342449.jpg

上記の状態で、192.168.11.73のホストが接続されているSwitch側のPortをshut。

1.切替時:25秒=Michaelの声が聴こえなかった
2.切戻時:2-3秒=Michaelの声が聴こえなかった

3.切替時:4秒=Ping疎通断
4.切戻時:2-3秒=Ping疎通断

全然気持ち良く聴けないんっすけど。。。

オレにとっては、1.が全然大事なんっすけど、
どうしてくれんじゃい!と。

んまぁ、でも
 「100Mps*2(FEC)接続じゃあ、ダメですね。」
と言われる環境なので、もうちょい方法を考えよう。

ちなみに、黒板五郎さんの配信はやめておいた。
号泣して検証どころではなくなってしまう。

「ほたるぅ~、、、いつでも富良野に帰ってくんだぞぉ~。」

今度はVMWareHAの方をやってみたいと思う。
DRSやDPMはやり方を検討中です。

[PR]
by mdesign21 | 2009-10-25 23:30 | IT系

ESX4.0 Teaming

ESX4.0側のTeaming設定と
Switch側のEtherChannel設定が
ようやく理解できてきた。

<ESX4.0側>
e0113173_21313485.jpg


vsp_40_esx_server_config_ja.pdf
にちょろっとだけ書いてあるのだけど、ポイントは2点。

・IPハッシュに基づいたルート
・リンク状態のみ

に設定すること。

気をつけることは、
「リンク状態のみ」→「ビーコンの検知」
にしちゃダメよんってこと。

最初はOKなんだけど、しばらくするとNGとなる。
そしてまたしばらくするとOKになる。
ってことを繰り返しちゃうので。

<Cat2950側>
interface Port-channel1
switchport trunk allowed vlan 11-13
switchport mode trunk
flowcontrol send off
spanning-tree portfast trunk
!
interface FastEthernet0/3
switchport trunk allowed vlan 11-13
switchport mode trunk
channel-group 1 mode on
spanning-tree portfast trunk
!
interface FastEthernet0/4
switchport trunk allowed vlan 11-13
switchport mode trunk
channel-group 1 mode on
spanning-tree portfast trunk

設定や動作はOKなんだけど、
1つのNICだけ、"u"になっちゃう。

cisco#sh etherchannel summary
Flags: D - down P - in port-channel
I - stand-alone s - suspended
H - Hot-standby (LACP only)
R - Layer3 S - Layer2
u - unsuitable for bundling
U - in use f - failed to allocate aggregator
d - default port

Number of channel-groups in use: 2
Number of aggregators: 2

Group Port-channel Protocol Ports
------+-------------+-----------+-----------------------------------------------
1 Po1(SU) - Fa0/3(u) Fa0/4(Pd)
2 Po2(SU) - Fa0/5(Pd) Fa0/6(P)

ML115のオンボードNICなんだけど、昨年ゲットしたものだから、
恐らく古いんだと思う。
今年に入ってゲットしたML115はOKなため。

今週中~来週には、IntelNICが到着するので、
それで再チャレンジかなと。

[PR]
by mdesign21 | 2009-10-24 21:47 | IT系

ESX4.0 SerialConsole接続を断念3


いじった箇所だけ書いておこ。

ホーム
>インベントリ
>ホストおよびクラスタ
>該当ホストを選択
>構成タブ
>ソフトウエア
>詳細設定

(1)
>VMKernel or BootどっちでもOK
 VMkernerl.Boot.baudrRate
 VMkernerl.Boot.debugLogToSerial
 VMkernerl.Boot.debugPort
 VMkernerl.Boot.serialPort
 VMkernerl.Boot.tty1Port
 VMkernerl.Boot.tty1Term
 VMkernerl.Boot.tty2Port
 VMkernerl.Boot.tty2Term
 VMkernerl.Boot.vmkKeyboard
 VMkernerl.Boot.vmkTerminals

(2)
>Misc
 Misc.serialPort
 Misc.DebugPort
 Misc.VMWirePort
 Misc.SerialBaudrRate

(1)をいじってからじゃないと、
(2)の一部はいじれなかったりしました。

この辺のサイトは確認したけど、ESX3x系なんだよね。
http://www.asahi-net.or.jp/~ym3y-oksm/nt/compaq/hp05.htm
http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=1003900

もちろん試したけど、NGでした。

どなたかD-sub9ピン経由でSerialConsole接続できたよ!って方、コメント求む。

そもそもは鯖の物理NICが2枚づつのため、
各Interfaceを別けて管理できなかったので、
無駄な頑張りをすることになってしまったわけです(^^;

NIC1=管理IP
NIC2&3(Teaming)=vNetwork、VMotion、FaulttolerantLogのIP

ってな具合で構成するため、EXPI9301CTを2つ発注しました。

ちなみに、まだGigaL3Switch導入はあきらめてなかったりw

「ポチっといっちゃないよ!」「ポチっといくのは一瞬だよ!」
っていう囁きが、頭から抜けない(笑)

・・・仕事頑張ればいっか?

もしくは、報奨金目当てで、しょぼい資格をピックアップするか?

少なくても、今回やってる技術を習得すれば、
習得時の初期費用よりも戻ってくる費用の方が
大きくなると想定されるから。

もちろん、初期費用が少ないに越したことはないんだが。。。

あんまり関係ないけど、今オレは半袖Tシャツ&半ズボンです。
機器の熱が部屋を暖めてくれますw

[PR]
by mdesign21 | 2009-10-24 17:18 | IT系

ESX4.0 SerialConsole接続を断念2

んで、結論としては、
ESX4.0起動時のLoggingやらDeubugを
SerialConsole上に表示させることはできたんだけど、
その後は止まってしまい、CLI操作はできなかった。

(上の方の出力は省略。)
0:00:02:27.441 cpu0:4096)VMNIX: Logger: 475: sysboot: Loading VMkernel Module 'cbt'
0:00:02:27.568 cpu2:4106)Loading module cbt ...
0:00:02:27.617 cpu2:4106)Elf: 2320: symbols tagged as
0:00:02:27.705 cpu1:4106)FDS: 211: cbt
0:00:02:27.745 cpu1:4106)Mod: 2892: Initialization for cbt succeeded with module ID 53.
0:00:02:27.837 cpu1:4106)cbt loaded successfully.

0:00:02:27.894 cpu0:4096)VMNIX: Logger: 475: sysboot: iommu ...
0:00:02:27.960 cpu0:4096)VMNIX: Logger: 475: sysboot: Executing 'esxcfg-init -m'
0:00:02:28.135 cpu0:4096)VMNIX: Logger: 475: sysboot: resource-groups ...
0:00:02:28.212 cpu0:4096)VMNIX: Logger: 475: sysboot: Executing 'esxcfg-resgrp -r'
0:00:02:28.332 cpu0:4096)VMNIX: Logger: 475: sysboot: aslr ...
0:00:02:28.398 cpu0:4096)VMNIX: Logger: 475: sysboot: Executing 'esxcfg-advcfg -s 1262807599 /UserMem/UserMemASRandomSeed'
0:00:02:28.559 cpu1:4106)Config: 289: "UserMemASRandomSeed" = 1262807599, Old Value: 796023369, (Status: 0x0)
0:00:02:28.674 cpu0:4096)VMNIX: Logger: 475: sysboot: store-logs ...
0:00:02:28.746 cpu0:4096)VMNIX: Logger: 475: sysboot: Executing 'mkdir -p /vmfs/volumes/4adf452d-5cb2fabb-457a-002481e1b552/esxconsole-4adf447f-1a80-cbc6-1400-001b21413ad7/
0:00:02:28.926 cpu0:4096)VMNIX: Logger: 475: logs'
0:00:02:29.011 cpu0:4096)VMNIX: Logger: 475: sysboot: Executing 'cp /var/log/sysboot-vmkernel-boot.log /vmfs/volumes/4adf452d-5cb2fabb-457a-002481e1b552/esxconsole-4adf447f
0:00:02:29.190 cpu0:4096)VMNIX: Logger: 475: -1a80-cbc6-1400-001b21413ad7/logs/sysboot-vmkernel-boot.log'
0:00:02:29.803 cpu0:4096)VMNIX: Logger: 475: sysboot: Executing 'cp /var/log/sysboot-dmesg-boot.log /vmfs/volumes/4adf452d-5cb2fabb-457a-002481e1b552/esxconsole-4adf447f-1a
0:00:02:29.982 cpu0:4096)VMNIX: Logger: 475: 80-cbc6-1400-001b21413ad7/logs/sysboot-dmesg-boot.log'
0:00:02:30.561 cpu0:4096)VMNIX: Logger: 475: sysboot: Executing 'cp /proc/vmware/log /vmfs/volumes/4adf452d-5cb2fabb-457a-002481e1b552/esxconsole-4adf447f-1a80-cbc6-1400-00
0:00:02:30.740 cpu0:4096)VMNIX: Logger: 475: 1b21413ad7/logs/sysboot-vmkernel-late.log'
0:00:02:31.269 cpu0:4096)VMNIX: Logger: 475: sysboot: Executing 'dmesg > "/vmfs/volumes/4adf452d-5cb2fabb-457a-002481e1b552/esxconsole-4adf447f-1a80-cbc6-1400-001b21413ad7/
0:00:02:31.448 cpu0:4096)VMNIX: Logger: 475: logs/sysboot-dmesg-late.log" 2> /dev/null'
0:00:02:32.027 cpu0:4096)VMNIX: Logger: 475: sysboot: Executing 'umount /sysroot'
0:00:02:32.113 cpu0:4096)VMNIX: Logger: 475: sysboot: Executing 'mount -o rw /sysroot'
0:00:02:32.227 cpu0:4096)VMNIX: Logger: 475: sysboot: Executing 'cp /sysroot/etc/vmware/esx.conf /sysroot/etc/vmware/esx.conf.old'
0:00:02:32.423 cpu0:4096)VMNIX: Logger: 475: sysboot: Executing 'cp /etc/vmware/esx.conf /sysroot/etc/vmware/esx.conf'
0:00:02:32.862 cpu0:4096)VMNIX: Logger: 475: sysboot: Executing 'umount /sysroot'
0:00:02:33.060 cpu0:4096)VMNIX: Logger: 475: sysboot: Executing 'mount -o ro /sysroot'
0:00:02:33.174 cpu0:4096)VMNIX: Logger: 475: sysboot: status-term ...
0:00:02:33.246 cpu0:4096)VMNIX: Logger: 475: sysboot: Executing 'esxcfg-init --set-boot-progress done'
0:00:02:33.444 cpu0:4096)VMNIX: Logger: 475: sysboot: Executing '/usr/lib/vmware/bin/vmdumper -g Boot Successful'
0:00:02:33.564 cpu0:4096)Boot Successful
0:00:02:33.606 cpu0:4096)VMNIX: Logger: 475: sysboot: switchroot ...
0:00:02:33.680 cpu0:4096)VMNIX: Logger: 475: sysboot: Executing 'cp /messages.log /vmfs/volumes/4adf452d-5cb2fabb-457a-002481e1b552/esxconsole-4adf447f-1a80-cbc6-1400-001b2
0:00:02:33.860 cpu0:4096)VMNIX: Logger: 475: 1413ad7/logs/sysboot.log'
0:00:02:34.409 cpu0:4096)VMNIX: Logger: 475: sysboot: Executing 'umount /vmfs'
0:00:02:34.492 cpu0:4096)VMNIX: Logger: 475: sysboot: Executing 'umount /sys'
0:00:02:34.574 cpu0:4096)VMNIX: Logger: 475: sysboot: Executing 'umount /dev/pts'
0:00:02:34.661 cpu0:4096)VMNIX: Logger: 475: sysboot: Switching root
0:00:02:34.732 cpu0:4096)VMNIX: Logger: 475: sysboot: Executing 'mount -o bind /dev /sysroot/dev'
0:00:02:34.857 cpu0:4096)VMNIX: Logger: 475: sysboot: Executing 'chmod 0755 /sysroot/dev'
0:00:02:34.950 cpu0:4096)VMNIX: Logger: 475: sysboot: Executing 'mount -t proc proc /sysroot/proc'
0:00:02:35.064 cpu0:4096)VMNIX: Logger: 475: sysboot: Executing 'mount -t sysfs sys /sysroot/sys'
0:00:02:37.460 cpu1:4097)NMP: nmp_CompleteCommandForPath: Command 0x12 (0x4100040464c0) to NMP device "mpx.vmhba2:C0:T0:L0" failed on physical path "vmhba2:C0:T0:L0" H:0x0 D:0x2 P:0x0 Valid sense data: 0x5 0x24 0x0.
0:00:02:37.683 cpu1:4097)ScsiDeviceIO: 747: Command 0x12 to device "mpx.vmhba2:C0:T0:L0" failed H:0x0 D:0x2 P:0x0 Valid sense data: 0x5 0x24 0x0.
0:00:02:37.844 cpu2:4098)NMP: nmp_CompleteCommandForPath: Command 0x12 (0x4100040464c0) to NMP device "mpx.vmhba2:C0:T0:L0" failed on physical path "vmhba2:C0:T0:L0" H:0x0 D:0x2 P:0x0 Valid sense data: 0x5 0x24 0x0.
0:00:02:38.068 cpu2:4098)ScsiDeviceIO: 747: Command 0x12 to device "mpx.vmhba2:C0:T0:L0" failed H:0x0 D:0x2 P:0x0 Valid sense data: 0x5 0x24 0x0.
0:00:02:38.609 cpu0:4096)CosCommon: 2224: irq 6 vector 0x31 (host 0x59)
0:00:02:38.683 cpu0:4096)IDT: 1038: 0x31 for host
0:00:02:38.736 cpu0:4096)IOAPIC: 1320: 0x31 retriggerred
0:00:02:41.817 cpu0:4096)CosCommon: 2156: irq 6 vector 0x31 (host 0x59)
0:00:02:44.739 cpu0:4096)Uplink: 8098: Setting capabilities 0x300 for device vmnic0
0:00:02:44.825 cpu0:4096)Uplink: 8098: Setting capabilities 0x3c002b for device vmnic0
0:00:02:48.878 cpu1:4105)Net: 1489: Enabling NIC in the shadow vmkernel tcpip stack
0:00:02:48.964 cpu1:4105)Tcpip_Vmk: 69: Opening COSSharedPort port = 0x4100018dcb00
0:00:02:49.052 cpu1:4105)Tcpip_Vmk: 312: txDisp 0x4100b8029180, rxDisp 0x4100b801f080
0:00:02:49.144 cpu1:4105)Tcpip_Interface: 834: No NIC support for TSO
0:00:02:49.218 cpu1:4105)Tcpip_Interface: 841: No NIC support for checksum offloading
0:00:02:49.308 cpu1:4105)Tcpip_Interface: 847: No NIC support for Scatter-Gather DMA
0:00:02:49.398 cpu1:4105)Tcpip_Vmk: 186: vmk0: Ethernet address: 00:50:56:4e:96:f9
0:00:02:49.485 cpu1:4105)Tcpip_Interface: 902: ether attach complete
0:00:02:53.630 cpu0:4096)Tcpip_Socket: 979: index = 100094024, ip_addr = 0x500ba8c0, netmask = 0xffffff
0:00:02:53.738 cpu0:4096)Tcpip_Vmk: 167: TcpipUpdateCOSInetAddr: (ifidx=4) added 192.168.11.80/255.255.255.0 status 0x0
0:00:02:53.863 cpu0:4096)Tcpip_Socket: 1087: add dstAddr=0xba8c0, netMask=0xffffff, gwAddr=0x4 ifName=0xb8033830, ifNameLen=4
0:00:02:53.995 cpu0:4096)Tcpip_Vmk: 353: (0xbad0005) IPv4 COSShadow route update failed: op 0 dst=192.168.11.0/255.255.255.0 gw= ifp=vmk0
0:00:02:54.193 cpu0:4096)Tcpip_Socket: 1087: add dstAddr=0x0, netMask=0x0, gwAddr=0xfe0ba8c0 ifName=0x0, ifNameLen=0
0:00:02:54.313 cpu0:4096)Tcpip_Vmk: 353: (0x0) IPv4 COSShadow route update succeeded: op 0 dst=0.0.0.0/0.0.0.0 gw=192.168.11.254 ifp=
0:00:02:54.462 cpu0:4096)Tcpip_Socket: 1087: add dstAddr=0xfea9, netMask=0xffff, gwAddr=0x4 ifName=0xb8033830, ifNameLen=4
0:00:02:54.589 cpu0:4096)Tcpip_Vmk: 353: (0x0) IPv4 COSShadow route update succeeded: op 0 dst=169.254.0.0/255.255.0.0 gw= ifp=vmk0
0:00:02:57.678 cpu1:4106)World: vm 4223: 1098: Starting world vobd with flags 4
0:00:02:58.189 cpu2:4107)Loading module vmfs2 ...
0:00:02:58.241 cpu2:4107)Elf: 2320: symbols tagged as
0:00:02:58.331 cpu1:4107)FSS: 571: Registered fs vmfs2, module 36, fsTypeNum 0xf520
0:00:02:58.417 cpu1:4107)Mod: 2892: Initialization for vmfs2 succeeded with module ID 54.
0:00:02:58.512 cpu1:4107)vmfs2 loaded successfully.

0:00:02:58.805 cpu2:4105)FSS: 3647: No FS driver claimed device '4adf451c-44169a27-5348-002481e1b552': Not supported
0:00:03:02.920 cpu2:4105)Loading module pclassify ...
0:00:03:02.975 cpu2:4105)Elf: 2320: symbols tagged as
0:00:03:03.069 cpu1:4105)Mod: 2892: Initialization for pclassify succeeded with module ID 55.
0:00:03:03.166 cpu1:4105)pclassify loaded successfully.

0:00:03:03.474 cpu1:4105)World: vm 4231: 1098: Starting world vmware-vmkauthd with flags 4
0:00:03:04.727 cpu0:4096)VMNIX: VGA: 462: 1
0:00:03:04.775 cpu0:4096)VMNIX: VGA: 462: 2
0:00:03:04.825 cpu0:4096)VMNIX: VGA: 462: 3
0:00:03:04.871 cpu0:4096)VMNIX: VGA: 462: 4
0:00:03:04.934 cpu0:4096)VMNIX: VGA: 462: 5
0:00:03:30.516 cpu2:4107)Config: 289: "VMOverheadGrowthLimit" = -1, Old Value: -1, (Status: 0x0)
0:00:03:30.682 cpu2:4098)NMP: nmp_CompleteCommandForPath: Command 0x12 (0x410004136400) to NMP device "mpx.vmhba2:C0:T0:L0" failed on physical path "vmhba2:C0:T0:L0" H:0x0 D:0x2 P:0x0 Valid sense data: 0x5 0x24 0x0.
0:00:03:30.906 cpu2:4098)ScsiDeviceIO: 747: Command 0x12 to device "mpx.vmhba2:C0:T0:L0" failed H:0x0 D:0x2 P:0x0 Valid sense data: 0x5 0x24 0x0.

んまぁでも、LoggingやDebugをゴリゴリ表示させる方法は理解できたかなと。。。
あんま意味ないけど(涙)

[PR]
by mdesign21 | 2009-10-24 15:48 | IT系

ESX4.0 SerialConsole接続を断念

D-Sub9ピン経由で、ESX4のbashを操作したかったので、
チャレンジしてみたが、結果として、断念することとなった。

これ以上、この点に時間を掛けられないので。

ESX4のCLI上で、tty周りの設定したところ、以下の表示まではできた。

いわゆるCentOSとかでも可能なSerialConsole接続の設定をしてみた。

これがそもそもの始まりだったんだけど。。。

以下、画面出力。

Press any key to continue.
Press any key to continue.
Press any key to continue.

GNU GRUB version 0.97 (639K lower / 2882176K upper memory)

+-------------------------------------------------------------------------+||||||||||||||||||||||||+-------------------------------------------------------------------------+
Use the ^ and v keys to select which entry is highlighted.
Press enter to boot the selected OS, 'e' to edit the
commands before booting, 'a' to modify the kernel arguments
before booting, or 'c' for a command-line. VMware ESX 4.0 Troubleshooting mode The highlighted entry will be booted automatically in 3 seconds. The highlighted entry will be booted automatically in 2 seconds. The highlighted entry will be booted automatically in 1 seconds. Booting 'VMware ESX 4.0'

root (hd0,0)
Filesystem type is ext2fs, partition type 0x83
uppermem 307200
kernel /vmlinuz ro root=UUID=7ac6f46f-4077-49c9-9963-e21531d1a0c2 mem=300M quie
ta console=tty0 console=ttyS0,9600n8r
[Linux-bzImage, setup=0x1e00, size=0x170d9c]
initrd /initrd.img
[Linux-initrd @ 0x119c5000, 0x122ac76 bytes]

[ 0.000000] Linux version 2.6.18-128.ESX (mts@pa-lin-bld371.eng.vmware.com) (gcc version 4.1.2) #1 Fri Apr 10 00:08:17 PDT 2009 [ESX Service Console build 159778]
[ 0.000000] Command line: ro root=UUID=7ac6f46f-4077-49c9-9963-e21531d1a0c2 mem=300M quieta console=tty0 console=ttyS0,9600n8r
[ 0.000000] BIOS-provided physical RAM map:
[ 0.000000] BIOS-e820: 0000000000000000 - 000000000009fc00 (usable)
[ 0.000000] BIOS-e820: 000000000009fc00 - 00000000000a0000 (reserved)
[ 0.000000] BIOS-e820: 00000000000e0000 - 0000000000100000 (reserved)
[ 0.000000] BIOS-e820: 0000000000100000 - 00000000affa0000 (usable)
[ 0.000000] BIOS-e820: 00000000affae000 - 00000000affb0000 type 9
[ 0.000000] BIOS-e820: 00000000affb0000 - 00000000affbe000 (ACPI data)
[ 0.000000] BIOS-e820: 00000000affbe000 - 00000000afff0000 (ACPI NVS)
[ 0.000000] BIOS-e820: 00000000afff0000 - 00000000afffe000 (reserved)
[ 0.000000] BIOS-e820: 00000000d0000000 - 00000000e0000000 (reserved)
[ 0.000000] BIOS-e820: 00000000fec00000 - 00000000fec01000 (reserved)
[ 0.000000] BIOS-e820: 00000000fee00000 - 00000000fef00000 (reserved)
[ 0.000000] BIOS-e820: 00000000ffa00000 - 0000000100000000 (reserved)
[ 0.000000] BIOS-e820: 0000000100000000 - 0000000250000000 (usable)
[ 0.000000] ESXSC: sc MA=[0,0x12c00000)
[ 0.000000] ESXSC: vmk MPN=[0x12c00,0xaff9f]
[ 0.000000] ESXSC: vmk MPN=[0x100000,0x24ffff]
[ 0.000000] DMI present.
[ 0.000000] Intel MultiProcessor Specification v1.4
[ 0.000000] Virtual Wire compatibility mode.
[ 0.000000] OEM ID: nVidia Product ID: MCP55 APIC at: 0xFEE00000
[ 0.000000] Processor #0 15:2 APIC version 16
[ 0.000000] Processor #1 15:2 APIC version 16
[ 0.000000] Processor #2 15:2 APIC version 16
[ 0.000000] Processor #3 15:2 APIC version 16
[ 0.000000] I/O APIC #4 Version 17 at 0xFEC00000.
[ 0.000000] vendor HP product ProLiant ML115 G5
[ 0.000000] Setting APIC routing to flat
[ 0.000000] Processors: 1
[ 0.000000] Nosave address range: 000000000009f000 - 00000000000a0000
[ 0.000000] Nosave address range: 00000000000a0000 - 00000000000e0000
[ 0.000000] Nosave address range: 00000000000e0000 - 0000000000100000
[ 0.000000] Allocating PCI resources starting at b0000000 (gap: afffe000:20002000)
[ 0.000000] Built 1 zonelists. Total pages: 74742
[ 0.000000] Kernel command line: ro root=UUID=7ac6f46f-4077-49c9-9963-e21531d1a0c2 mem=300M quieta console=tty0 console=ttyS0,9600n8r
[ 0.000000] Initializing CPU#0
[ 0.000000] PID hash table entries: 2048 (order: 11, 16384 bytes)
[ 0.000000] Using PIT for base-timer
[ 67.579654] time.c: Using 1.193182 MHz WALL PIT GTOD PIT/TSC timer.
[ 67.579657] time.c: Detected 2000.009 MHz processor.
[ 67.587169] Console: colour VGA+ 80x25
[ 70.581273] Dentry cache hash table entries: 65536 (order: 7, 524288 bytes)
[ 70.664694] Inode-cache hash table entries: 32768 (order: 6, 262144 bytes)
[ 70.748763] Memory: 279356k/307200k available (2047k kernel code, 27264k reserved, 889k data, 160k init)
[ 71.003002] Calibrating delay using timer specific routine.. 4004.00 BogoMIPS (lpj=20020044)
[ 71.104107] Security Framework v1.0.0 initialized
[ 71.160364] SELinux: Initializing.
[ 71.202093] selinux_register_security: Registering secondary module capability
[ 71.289420] Capability LSM initialized as secondary
[ 71.347758] Mount-cache hash table entries: 256
[ 71.401910] CPU: L1 I Cache: 64K (64 bytes/line), D cache 64K (64 bytes/line)
[ 71.487236] CPU: L2 Cache: 512K (64 bytes/line)
[ 71.541421] CPU: AMD Phenom(tm) 9350e Quad-Core Processor stepping 03
[ 71.618878] ExtINT not setup in hardware but reported by MP table
[ 71.691900] Using IO-APIC 4
[ 71.825493] checking if image is initramfs... it is
[ 73.075147] Freeing initrd memory: 18603k freed
[ 73.135557] NET: Registered protocol family 16
[ 73.188768] PCI: Using configuration type 1
[ 73.238931] SCSI subsystem initialized
[ 73.283787] PCI: Probing PCI hardware
[ 73.328136] PCI: Transparent bridge - 0000:00:06.0
[ 73.392881] PCI: Using IRQ router default [10de/0360] at 0000:00:01.0
[ 73.469924] PCI->APIC IRQ transform: 0000:00:01.1[A] -> IRQ 19
[ 73.539678] PCI->APIC IRQ transform: 0000:00:02.0[A] -> IRQ 16
[ 73.609420] PCI->APIC IRQ transform: 0000:00:02.1[B] -> IRQ 16
[ 73.679163] PCI->APIC IRQ transform: 0000:00:05.0[A] -> IRQ 18
[ 73.748901] PCI->APIC IRQ transform: 0000:00:05.1[B] -> IRQ 19
[ 73.818646] PCI->APIC IRQ transform: 0000:00:05.2[C] -> IRQ 17
[ 73.888404] PCI->APIC IRQ transform: 0000:04:00.0[A] -> IRQ 17
[ 73.958052] PCI->APIC IRQ transform: 0000:10:00.0[A] -> IRQ 18
[ 74.027795] PCI->APIC IRQ transform: 0000:11:00.0[A] -> IRQ 18
[ 74.097749] PCI: Bridge: 0000:00:06.0
[ 74.141532] IO window: disabled.
[ 74.182215] MEM window: disabled.
[ 74.223934] PREFETCH window: disabled.
[ 74.270830] PCI: Bridge: 0000:00:0a.0
[ 74.314623] IO window: disabled.
[ 74.355288] MEM window: disabled.
[ 74.396991] PREFETCH window: disabled.
[ 74.443885] PCI: Bridge: 0000:00:0b.0
[ 74.487673] IO window: disabled.
[ 74.528337] MEM window: disabled.
[ 74.570053] PREFETCH window: disabled.
[ 74.616949] PCI: Bridge: 0000:00:0c.0
[ 74.660733] IO window: e000-efff
[ 74.701407] MEM window: fcf00000-fcffffff
[ 74.751423] PREFETCH window: disabled.
[ 74.798326] PCI: Bridge: 0000:00:0d.0
[ 74.842110] IO window: disabled.
[ 74.882781] MEM window: fd000000-fdefffff
[ 74.932791] PREFETCH window: fb000000-fbffffff
[ 74.987998] PCI: Bridge: 0000:00:0e.0
[ 75.031787] IO window: disabled.
[ 75.072460] MEM window: fdf00000-fdffffff
[ 75.122469] PREFETCH window: disabled.
[ 75.169369] PCI: Bridge: 0000:00:0f.0
[ 75.213163] IO window: disabled.
[ 75.253827] MEM window: disabled.
[ 75.295539] PREFETCH window: disabled.
[ 75.342511] NET: Registered protocol family 2
[ 75.494300] IP route cache hash table entries: 4096 (order: 3, 32768 bytes)
[ 75.577595] TCP established hash table entries: 16384 (order: 5, 131072 bytes)
[ 75.664025] TCP bind hash table entries: 8192 (order: 4, 65536 bytes)
[ 75.741061] TCP: Hash tables configured (established 16384 bind 8192)
[ 75.818078] TCP reno registered
[ 75.856359] audit: initializing netlink socket (disabled)
[ 75.920920] type=2000 audit(1256320733.290:1): initialized
[ 75.986554] Total HugeTLB memory allocated, 0
[ 76.038707] VFS: Disk quotas dquot_6.5.1
[ 76.085629] Dquot-cache hash table entries: 512 (order 0, 4096 bytes)
[ 76.162685] squashfs: version 3.2-alpha (2006/12/12) Phillip Lougher
[ 76.238689] fuse init (API version 7.7)
[ 76.342649] Initializing Cryptographic API
[ 76.391636] alg: No test for crc32c (crc32c-generic)
[ 76.451003] ksign: Installing public key data
[ 76.503095] Loading keyring
[ 76.536498] io scheduler noop registered
[ 76.583557] io scheduler anticipatory registered
[ 76.638915] io scheduler deadline registered
[ 76.690127] io scheduler cfq registered (default)
[ 76.772791] assign_interrupt_mode Found MSI capability
[ 76.834309] assign_interrupt_mode Found MSI capability
[ 76.895811] assign_interrupt_mode Found MSI capability
[ 76.957306] assign_interrupt_mode Found MSI capability
[ 77.018811] assign_interrupt_mode Found MSI capability
[ 77.080310] assign_interrupt_mode Found MSI capability
[ 77.141784] pci_hotplug: PCI Hot Plug PCI Core version: 0.5
[ 77.209683] Real Time Clock Driver v1.12ac
[ 77.265185] Linux agpgart interface v0.101 (c) Dave Jones
[ 77.329770] Serial: 8250/16550 driver $Revision: 1.90 $ 4 ports, IRQ sharing enabled
[ 77.422485] serial8250: ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
[ 77.494536] RAMDISK driver initialized: 1 RAM disks of 307200K size 1024 blocksize
[ 77.585263] loop: loaded (max 8 devices)
[ 77.632266] Linux video capture interface: v2.00
[ 77.953560] serio: i8042 KBD port at 0x60,0x64 irq 1
[ 78.012973] mice: PS/2 mouse device common for all mice
[ 78.077071] TCP bic registered
[ 78.113591] Initializing IPsec netlink socket
[ 78.165693] NET: Registered protocol family 1
[ 78.217793] NET: Registered protocol family 17
[ 78.270957] Freeing unused kernel memory: 160k freed
* vmnix ...

ただ、この「 * vmnix ...」が表示された時点で、
Consoleの画面出力が止まってしまったので、
vSphareClientの詳細設定をいじり始めてしまった訳です。

[PR]
by mdesign21 | 2009-10-24 15:42 | IT系

tshark

言わずもがな、wiresharkのCLI版。

訳アリで長期間Capをすることとなったため、
対応策を検討した結果、tsharkを使うことにした。

重要
ファイルサイズで指定するより、時間で指定した方がdrop確率は低減する。
600MBファイルをコピーした際のCapを実施したところ、
 ファイルサイズ指定
  10MB時4000パケット程度Drop
  20MB時500パケット程度Drop
 といった具合。
これに対して、
 時間指定
  3秒間隔Drop無し
  5秒間隔Drop無し
 といった結果でした。

以下、主要Optionの説明

<キャプチャ準備>
Interface番号&名前を調べる
-D

Cap対象Interface番号を指定する
-i 3

<キャプチャ準備>
ファイルサイズ(KB単位)を指定して保存する
下記の例では5KBに達したら次のファイルを自動生成&保存する
-b filesize:5

経過時間(Sec単位)を指定して保存する
下記の例では5秒ごとに次のファイルを自動生成&保存する
-b duration:5

保存先ファイルパス&ファイル名を設定する
ファイル名と拡張子の間にSeq番号と日時が勝手に入ってくる
例 test.pcap→test_00351_20091023004425.pcap

-w r:\test.pcap

名前解決全無効 長期間Cap時は必須
-n


"C:\Program Files\Wireshark\tshark.exe" -n -i 3 -w r:\test.pcap -b duration:10

・名前解決はせず、Interface番号3をキャプチャ
・r:\test.pcapというファイル名で10秒ごとに保存する

ちなみに時間指定で区切られるため、
Capファイルをマージしたくなるのが人情。
なので、以下に記載。単純に合体しちゃうだけです。


"C:\Program Files\Wireshark\mergecap.exe" -w r:\test10.pcap r:\test_8.pcap r:\test_1.pcap

mergecap.exe -w Marge後ファイル(絶対パス) MargeしたいファイルA(絶対パス) MargeしたいファイルB(絶対パス)

今夜のVMはお休み。
ESX4.0へシリアルコンソール接続したいっす!
けど、起動中「vmnix」がコンソール表示されて止まるっす。
OS起動自体は正常なのに。。。

n1kv案件の話を小耳に挟んだ。
けど、オレから「やりたい!」などとは言わん。
それと無しに話を広めて、「やってくれないか?」と言われるまで待つ。

 何かを得るためには相応の代償が必要です。
 何を代償として差し出せますか?
なスタンスなので。

[PR]
by mdesign21 | 2009-10-23 01:12 | IT系

ESX4.0 構成ガイド

ふてくされモードで再インストしているわけだが、
ESX構成ガイドを読んでいたら、68ページにこんな記述があったw

~・~・~・~・~・~・~・~・~・~・~・~・~・~・~・~・~・~・~・~
<ポート グループの構成に関するトラブルシューティング>
省略

使用されていたネットワークの名前を変更することは避けてください。
ポート グループの名前を変更したら、関連する各仮想マシンを
サービス コンソールを使用して再構成し、
新しいポート グループ名を反映させる必要があります。
~・~・~・~・~・~・~・~・~・~・~・~・~・~・~・~・~・~・~・~

へいへい、わかりやした。

とにかく最初の設計が肝なわけですな。と。

ここにツラツラ書くと、スキルの無さがあかるみにw

ちなみに、もう1つあかるみにしちゃうと、

ESX4.0は、Kernerl2.6系のLinuxと、どこか違うのか?未だにあんまりわかってないっす(爆)

「VMなんちゃら」っていうサービスがいっぱい起動しているだけとしか思えないんだけど。。。

「そんなことあるか!」ってぶっ飛ばされちゃいそうなので、これ以上書くのはやめとこ。

[PR]
by mdesign21 | 2009-10-22 02:45 | IT系

ESX4.0 再インスト

vDS(v分散スイッチ)の設定でいろいろとゴリゴリしていたら、

IP疎通性が全く取れない状況となってしまい、

あえなく再インストとなってしまった(涙)

UplinkやらPortGroupやらの各インターフェース上に名前を付けたらNGとなった。

トラシュのため、
 1.キャプってみたり
 2.モニタ&キーボードを繋いでConsole画面確認したり
 3.「シメるぞ、ゴルァ!」とML115にガンくれてみたり
したけど、やっぱりダメだった。

んで、
 1はOKとして、
 2を毎回やるのは辛いのでD-sub9ピンでアクセスできるようにしよ♪
 3は、、、念のため、やってみたw
ので、気を取り直してもう一回チャレンジですな。

[PR]
by mdesign21 | 2009-10-22 02:16 | IT系

ESX4.0 vCenterServer

途方もない場所に迷い込んだ予感がする。。。

vSphareClientからvCenterServerへログインできないことがたびたび発生する。

原因は置いておいて、Workaroundとして、地味なことをしてます。

とりあえず、Win2003 on VMWS2.0にて、telnetサービスをEnbaleにして、

telnetログイン後に"net start vctomcat"ってな具合でサービスを起動。

何とかせねばだけど、他にいっぱいやることはある。


あと、やっぱり各機器をShutdownする順番って結構大事。

例えば、iSCSIを先にDownさせてから、

ESXをDownさせると、ESXが固まってたっぽいw


それと、いろいろやってて思うことは、

だんだんオレが予想していた時代に

差し掛かっているような気がすること。


L3SWゴリゴリするしかないぜ!ってな人は、確実に沙汰されていく。

もう目の前まで来ている。。。

[PR]
by mdesign21 | 2009-10-21 02:31 | IT系

ESX4.0 Network

Network設定でこんなにつまづくとは思わなかったぜぃ。

途中から構成を変えようとするからなんだけど、

実際にやるときはきちんと設計しないと、あれ?繋がらないっす。

ってことになりかねん。

まだ、イマイチわかっていないのが、VLAN ID(任意)の設定かな。

Cat2950側でnative vlan設定を入れず、Trunkのみにしてあるのに、
なぜか?ESX側でVLAN ID=なし、となっているインターフェースへ
IPにて疎通できてしまう。

あとは、vDSには興味ありで、こちらもいじらねばね。

それとは、別件でStorageを削除する際の順番は肝ですな。

順番の問題なのだけど、vCenterServer上でいじると、やたら時間が掛かる。

[PR]
by mdesign21 | 2009-10-21 01:24 | IT系