Metaphorical Dream

<   2008年 11月 ( 15 )   > この月の画像一覧

PC2台

会社からPCが2台支給された。
ノート1台(以前Diaryに載せたD430)と、デスクトップ1台(Dellの何かだった気がする)
共にメモリ2G
けど、デスクトップのHDDが80GBって、ありえなくねぇ?

さて、どう料理しよ?

とりあえず、どちらのPCもセットアップ前にTI(以後、TrueImageの略にしよ)してるから、いつでも支給直後に戻せるし。

ノートはSafeBootが入ってるからあんまりいじらない&いじれないけど、デスクトップはウザイ系のソフトがウイスルバスターしか入ってない(と言っても支給直後は入ってない)。

なので、VMC(VMWareConverter)してから、メモリ8Gにアップして、HDDフォーマットして、CentOS&VMWS2.0ぶち込んで、元のOSをVM上で稼動させるか?(笑)
それでもあと6GBのメモリが残るから、ゴリゴリ検証できる。

XP32bitじゃあ、話にならんのだけど、ちょいと考えよう。

これからの時代はメモリ8GB、HDD500GBをデフォルトとして推奨したいと思うのは、オレだけじゃないハズだ!

そうだ!ESXiで起動するか?を検証してみっか!
たとえ、会社の情シスや所属部署の本部長クラスがNG出したって、
「だったら代表取締役に聞いてみろよぉ?うちの会社にとって仮想化がどういう位置付けなのか?」
って言えば、社長からのお許しが出たりするのだろうか(爆)

それで、社長から推奨されちゃったら、腹抱えて笑っちゃうんだけどなぁ。

[PR]
by mdesign21 | 2008-11-28 01:10 | Diary

Cat2950T-24

はぁ~、ゲットしてしまった。。。

だって、Labパッケージとして売れそうなくらい良い組合せなんだもん。

っていうのは、言い訳かぁ。。

んまぁ、1万円で各VLANからタコ足できるぜ!って思えば、
かなりイケてるだろ?って思うのであります。

「いいから、黙って使ってみろよ!」と言えるくらいのモノであることは確かだと思う。。。

[PR]
by mdesign21 | 2008-11-25 23:45 | Diary

Linux CentOS5.2 Bonding&VLAN Interface作成

Bonding Interfaceの中にVLAN Interfaceで生成されたトラフィック(VLANタグが付いたEtherフレーム)を
流してみたくなるのが、ネットワークエンジニアなわけですよ。
ってことで、以下を試してみた。結果から言うと成功してる。

(1)
まず、bond0の設定ファイルを開き、IPADDR設定などをぶっ飛ばす。
#でコメントアウトするだけでもOKだよ。
それと、「BOOTPROTO=none」にしておく。
ようするに、VLAN Interface作成時と同様にeth1とかの物理NICと同じ設定を
bond0に設定してやるわけです。

vi /etc/sysconfig/network-scripts/ifcfg-bond0

DEVICE=bond0
BOOTPROTO=none
ONBOOT=yes


(2)
以下のファイルを開き、「VLAN_NAME_TYPE=」に「VLAN_PLUS_VID_NO_PAD」を設定しておく。
「DEV_PLUS_VID_NO_PAD」でもOKだと思うけど、雰囲気が出ないじゃん?

vi /etc/sysconfig/network

VLAN=yes
VLAN_NAME_TYPE=VLAN_PLUS_VID_NO_PAD


(3)
以下のファイル(ifcfg-vlan100)を開き、「PHYSDEV=bond0」にしておく。
上にも記載したけど、eth1とかの物理NIC内にVLAN100のトラフィックを流すのと同様に
bond0内にVLAN100のトラフィックを流すってイメージになる。

vi /etc/sysconfig/network-scripts/ifcfg-vlan100

DEVICE=vlan100
BOOTPROTO=static
ONBOOT=yes
PHYSDEV=bond0
IPADDR=192.168.100.10
NETMASK=255.255.255.0
NETWORK=192.168.100.0
BROADCAST=192.168.100.255

(4)
以下のファイル(ifcfg-vlan110)を開き、こちらも「PHYSDEV=bond0」にしておく。

vi /etc/sysconfig/network-scripts/ifcfg-vlan110

DEVICE=vlan110
BOOTPROTO=static
ONBOOT=yes
PHYSDEV=bond0
IPADDR=192.168.110.10
NETMASK=255.255.255.0
NETWORK=192.168.110.0
BROADCAST=192.168.110.255


(5)
んでもって、netwrokサービスをリスタートしてやる。
↓こんな感じの表示になればOK。

/etc/rc.d/init.d/network restart

インターフェース bond0 を終了中: [ OK ]
インターフェース eth0 を終了中: [ OK ]
ループバックインターフェースを終了中 [ OK ]
ループバックインターフェイスを呼び込み中 [ OK ]
802.1Q VLAN パラメーターを設定中: Set name-type for VLAN subsystem. Should be visible in /proc/net/vlan/config
[ OK ]
インターフェース bond0 を活性化中: [ OK ]
インターフェース eth0 を活性化中: [ OK ]
インターフェース vlan100 を活性化中: Added VLAN with VID == 100 to IF -:bond0:-
[ OK ]
インターフェース vlan110 を活性化中: Added VLAN with VID == 110 to IF -:bond0:-
[ OK ]


(6)
ifconfigの結果は以下の通り。

ifconfig
bond0 Link encap:Ethernet HWaddr 00:1B:21:2A:5F:E9
inet6 addr: fe80::21b:21ff:fe2a:5fe9/64 Scope:Link
UP BROADCAST RUNNING MASTER MULTICAST MTU:1500 Metric:1
RX packets:12624 errors:0 dropped:0 overruns:0 frame:0
TX packets:12848 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:3344504 (3.1 MiB) TX bytes:3220815 (3.0 MiB)

eth1 Link encap:Ethernet HWaddr 00:1B:21:2A:5F:E9
inet6 addr: fe80::21b:21ff:fe2a:5fe9/64 Scope:Link
UP BROADCAST RUNNING SLAVE MULTICAST MTU:1500 Metric:1
RX packets:360 errors:0 dropped:0 overruns:0 frame:0
TX packets:6291 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:100
RX bytes:225920 (220.6 KiB) TX bytes:1555896 (1.4 MiB)

eth2 Link encap:Ethernet HWaddr 00:1B:21:2A:5F:E9
inet6 addr: fe80::21b:21ff:fe2a:5fe9/64 Scope:Link
UP BROADCAST RUNNING SLAVE MULTICAST MTU:1500 Metric:1
RX packets:12264 errors:0 dropped:0 overruns:0 frame:0
TX packets:6557 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:100
RX bytes:3118584 (2.9 MiB) TX bytes:1664919 (1.5 MiB)

vlan100 Link encap:Ethernet HWaddr 00:1B:21:2A:5F:E9
inet addr:192.168.100.10 Bcast:192.168.100.255 Mask:255.255.255.0
inet6 addr: fe80::21b:21ff:fe2a:5fe9/64 Scope:Link
UP BROADCAST RUNNING MASTER MULTICAST MTU:1500 Metric:1
RX packets:2008 errors:0 dropped:0 overruns:0 frame:0
TX packets:5573 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:205204 (200.3 KiB) TX bytes:595222 (581.2 KiB)

vlan110 Link encap:Ethernet HWaddr 00:1B:21:2A:5F:E9
inet addr:192.168.110.10 Bcast:192.168.110.255 Mask:255.255.255.0
inet6 addr: fe80::21b:21ff:fe2a:5fe9/64 Scope:Link
UP BROADCAST RUNNING MASTER MULTICAST MTU:1500 Metric:1
RX packets:3631 errors:0 dropped:0 overruns:0 frame:0
TX packets:36 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:353410 (345.1 KiB) TX bytes:8620 (8.4 KiB)


若干問題になりそうな点を記載しておくと、
MAC Addressがみんな同じになってるってこと。
「HWaddr 00:1B:21:2A:5F:E9」

Linux上でrouteを書いちゃったりすると、片側に寄ったりする可能性はあり得る。


ただ、まぁ、とりあえず、これでCiscoのL3-Switchと接続した際に
きちんとEtherChannelがLinkUpするか?
Routing可能か?
ってことを確認できればOKなので。


(7)
ってことで、以下、Cat3560-8PCのConfigサンプルを記載

Switch#sh run
Building configuration...

Current configuration : 1468 bytes
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Switch
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
system mtu routing 1500
vtp mode transparent
ip subnet-zero
ip routing
!
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
vlan 100,110,120
!
interface Port-channel1
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 100,110
switchport mode trunk
spanning-tree portfast trunk
!
interface FastEthernet0/1
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 100,110
switchport mode trunk
channel-group 1 mode on
!
interface FastEthernet0/2
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 100,110
switchport mode trunk
channel-group 1 mode on
!
interface FastEthernet0/3
switchport access vlan 120
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface GigabitEthernet0/1
!
interface Vlan1
no ip address
shutdown
!
interface Vlan100
ip address 192.168.100.1 255.255.255.0
!
interface Vlan110
ip address 192.168.110.1 255.255.255.0
!
interface Vlan120
ip address 192.168.120.1 255.255.255.0
!
ip classless
ip http server
!
!
!
control-plane
!
!
line con 0
line vty 5 15
!
end


(8)
上記のConfigでLinuxとCat3560をLayer3EtherChannelとして接続ができたw

以下、Cat3560側のLog

Switch#sh etherchannel summary
Flags: D - down P - bundled in port-channel
I - stand-alone s - suspended
H - Hot-standby (LACP only)
R - Layer3 S - Layer2
U - in use f - failed to allocate aggregator

M - not in use, minimum links not met
u - unsuitable for bundling
w - waiting to be aggregated
d - default port


Number of channel-groups in use: 1
Number of aggregators: 1

Group Port-channel Protocol Ports
------+-------------+-----------+-----------------------------------------------
1 Po1(SU) - Fa0/1(P) Fa0/2(P)

この状態でVlan-int120(f0/3)にPCを接続し、ExPingでシビアにPing打ってみる。

宛先1:192.168.100.10
宛先2:192.168.110.10
実行間隔:1ms
ブロックサイズ:64bytes
タイムアウト:100ms

そんでもって、UTPの抜き差しを実施すると、
抜線時
 f0/1=Ping落ちず
 f0/2=Ping1発落ち
結線時
 f0/1=Ping5~6発落ち
 f0/2=Ping5~6発落ち
ってな具合で、
VLAN Interface&BondingInterfaceが正常に稼動してることが確認できた。


(9)
総評

今回はCat3560側のVlan120からPCにてPingを打った。
けど、実際の使い方としては、そんなくだらんことはしない。

ESXiでは、VLAN Interfaceを容易に作成し、各仮想OSのNICにアサインすることができるけど、
VMWS2.0 forLinux版では、Linux側の設定が必要だなぁ~と思ってた。

VMWS2.0 forWindows版の場合は、GUIで比較的容易に設定可能だから、
わざわざDoc化せんでも大丈夫なんだけどね。
とは言っても、Windowsの場合は、VLANに対応したNICが必須だけどね。
(intel EXPI9300PT PRO/1000 PT Desktop Adapterとかがオススメかなと。)

ちなみに、VMWS2.0 forLinux版にて、vmnetとVLAN-intをマッピングするには、
再度「/usr/bin/vmware-config.pl」を叩く必要がある。
こちらについては「yes&noを何度か繰り返せば解るよ」と言いたいところだけど、
以下にCLIの結果だけ記載しておこう。

~・~・~・~・~・~・~・~・~・~・~・~・~・~・~・~・~・~・~・~・~・~
/usr/bin/vmware-config.pl
Making sure services for VMware Server are stopped.

Stopping VMware autostart virtual machines:
Virtual machines [ OK ]
Stopping VMware management services:
VMware Virtual Infrastructure Web Access
VMware Server Host Agent [ OK ]
Stopping VMware services:
VMware Authentication Daemon [ OK ]
VM communication interface socket family: [ OK ]
Virtual machine communication interface [ OK ]
Virtual machine monitor [ OK ]

The bld-2.6.18-8.el5-x86_64smp-RHEL5 - vmmon module loads perfectly into the
running kernel.

The bld-2.6.18-8.el5-x86_64smp-RHEL5 - vmci module loads perfectly into the
running kernel.

The bld-2.6.18-8.el5-x86_64smp-RHEL5 - vsock module loads perfectly into the
running kernel.

Do you want networking for your virtual machines? (yes/no/help) [no] yes

Configuring a bridged network for vmnet0.

Please specify a name for this network.
[Bridged] VLAN100

Your computer has multiple ethernet network interfaces available: bond0, eth0,
eth1, eth2, vlan100, vlan110. Which one do you want to bridge to vmnet0?
[eth0] vlan100

The following bridged networks have been defined:

. vmnet0 is bridged to vlan100

Do you wish to configure another bridged network? (yes/no) [no] yes

Configuring a bridged network for vmnet2.

Please specify a name for this network.
[Bridged] VLAN110

Your computer has multiple ethernet network interfaces available: bond0, eth0,
eth1, eth2, vlan110. Which one do you want to bridge to vmnet2? [eth0] vlan110

The following bridged networks have been defined:

. vmnet0 is bridged to vlan100
. vmnet2 is bridged to vlan110

Do you wish to configure another bridged network? (yes/no) [no] no

Do you want to be able to use NAT networking in your virtual machines? (yes/no)
[yes] no

Do you want to be able to use host-only networking in your virtual machines?
[no] no

The bld-2.6.18-8.el5-x86_64smp-RHEL5 - vmnet module loads perfectly into the
running kernel.

あとは、普通に「/usr/bin/vmware-config.pl」を叩いたときと同じです。

~・~・~・~・~・~・~・~・~・~・~・~・~・~・~・~・~・~・~・~・~・~

これを実施することにより、1つの物理NICに対して、Linux上に複数のVLAN Interfaceを作成し、
尚且つ、VMWare上の仮想OSのNICを任意のVLAN Interfaceにマッピングすることで、
対向にTrunk可能なスイッチがあれば、まさに鼻血が止まらなくなりそうな検証環境を構築できる。
ちなみにVMWS2.0側でVLAN Interfaceをマッピングすると以下のような表示になる。
e0113173_23211950.jpg


Cat2950T-24が欲しくなるわけだ。

[PR]
by mdesign21 | 2008-11-24 23:17 | Diary

Linux CentOS5.2 Bonding Interface作成

(1)
以下のファイルを開く。

vi /etc/modprobe.conf


(2)
Linux自体でBonding InterfaceをEnableにする。

alias bond0 bonding
options bonding mode=0 miimon=200

Optionのモード設定などは以下のURLを参照
http://www.redhat.com/docs/manuals/enterprise/RHEL-4-Manual/ja/ref-guide/s1-modules-ethernet.html


(3)
Bonding Interfaceの設定ファイルを作成する。

vi /etc/sysconfig/network-scripts/ifcfg-bond0

DEVICE=bond0
BOOTPROTO=none
ONBOOT=yes
IPADDR=192.168.100.10
NETMASK=255.255.255.0
NETWORK=192.168.100.0
BROADCAST=192.168.100.255


(4)
eth1をBonding Interfaceに加える

vi /etc/sysconfig/network-scripts/ifcfg-eth1

# Intel Corporation 82572EI Gigabit Ethernet Controller (Copper)
DEVICE=eth1
ONBOOT=yes
BOOTPROTO=static
HWADDR=00:1b:21:2a:5f:e9
MASTER=bond0
SLAVE=yes


(5)
eth2をBonding Interfaceに加える

vi /etc/sysconfig/network-scripts/ifcfg-eth2

# Intel Corporation 82572EI Gigabit Ethernet Controller (Copper)
DEVICE=eth2
ONBOOT=yes
BOOTPROTO=none
HWADDR=00:1b:21:2a:5e:67
MASTER=bond0
SLAVE=yes


(6)
んでもって、ifupとかやればOKなんだけど、
「きちんとBondingされたぜ!」ってところを見たければ、
netwrokサービスをリスタートしましょ。

/etc/rc.d/init.d/network restart

インターフェース eth0 を終了中: [ OK ]
インターフェース eth1 を終了中: [ OK ]
インターフェース eth2 を終了中: [ OK ]
ループバックインターフェースを終了中 [ OK ]
ループバックインターフェイスを呼び込み中 [ OK ]
インターフェース bond0 を活性化中: [ OK ]
インターフェース eth0 を活性化中: [ OK ]

上記のように終了するときは、eth1とeth2が表示されるけど、
起動するときは、bond0のみになってればOKかなと。

[PR]
by mdesign21 | 2008-11-23 23:25 | Diary

Linux CentOS5.2 VLAN Interface作成

(1)
以下のファイルを開く。

vi /etc/sysconfig/network


(2)
Linux自体で802.1qをEnableにする

VLAN=yes
VLAN_NAME_TYPE=DEV_PLUS_VID_NO_PAD

VLAN_NAME_TYPEの詳細は(6)にて解説


(3)
物理NICのIP-AddressをOFFにする

vi /etc/sysconfig/network-scripts/ifcfg-ethX

X=0からの数字。一番最初にあるNICが0になる。
今回は増設NICのため、1となる。

↓こんな感じ。
# Intel Corporation 82572EI Gigabit Ethernet Controller (Copper)
DEVICE=eth1
ONBOOT=yes
BOOTPROTO=none
HWADDR=00:1b:21:2a:5f:e9

↓IPアドレスの設定を消すのが不安ならこんな感じで#にてコメントアウトしてもOK

# Intel Corporation 82572EI Gigabit Ethernet Controller (Copper)
DEVICE=eth1
ONBOOT=yes
BOOTPROTO=none
HWADDR=00:1b:21:2a:5f:e9
#IPADDR=192.168.11.31
#NETMASK=255.255.255.0
#NETWORK=192.168.11.0
#BROADCAST=192.168.11.255


(4)
論理NIC(=VLAN Interface)の作成

vi /etc/sysconfig/network-scripts/ifcfg-eth1.100

以下のような設定してみる。

DEVICE=eth1.100
BOOTPROTO=static
ONBOOT=yes
IPADDR=192.168.100.10
NETMASK=255.255.255.0


もう一個作ってみよ。

vi /etc/sysconfig/network-scripts/ifcfg-eth1.200

以下のような設定してみる。

DEVICE=eth1.200
BOOTPROTO=static
ONBOOT=yes
IPADDR=192.168.200.10
NETMASK=255.255.255.0


(5)
んでもって、ifupとかやればOKなんだけど、
「きちんとVLANが作られるぜ!」ってところを見たければ、
netwrokサービスをリスタートしましょ。

/etc/rc.d/init.d/network restart

↓こんな感じでメッセージが表示されればOK。

インターフェース eth0 を終了中: [ OK ]
インターフェース eth1 を終了中: [ OK ]
ループバックインターフェースを終了中 [ OK ]
ループバックインターフェイスを呼び込み中 [ OK ]
802.1Q VLAN パラメーターを設定中: Set name-type for VLAN subsystem. Should be visible in /proc/net/vlan/config
[ OK ]
インターフェース eth0 を活性化中: [ OK ]
インターフェース eth1 を活性化中: [ OK ]
インターフェース eth1.100 を活性化中: Added VLAN with VID == 100 to IF -:eth1:-
[ OK ]
インターフェース eth1.200 を活性化中: Added VLAN with VID == 200 to IF -:eth1:-
[ OK


(6)
VLAN Interfaceの表記方法(ファイル名)を変える。

またまた、以下のファイルを開く。

vi /etc/sysconfig/network

「VLAN_NAME_TYPE=」の値によってifcfg-」の後の表記が変わります。

VLAN_PLUS_VID⇒vlan0100
VLAN_PLUS_VID_NO_PAD⇒vlan100
DEV_PLUS_VID⇒eth0.0100
DEV_PLUS_VID_NO_PAD⇒eth0.100

例えば、
vi /etc/sysconfig/network
にて、以下のように記述する

VLAN=yes
VLAN_NAME_TYPE=VLAN_PLUS_VID_NO_PAD

ip addressを設定する際は以下のようにする

vi /etc/sysconfig/network-scripts/ifcfg-vlan100


DEVICE=vlan100
BOOTPROTO=static
ONBOOT=yes
PHYSDEV=eth1
IPADDR=192.168.100.1
NETMASK=255.255.255.0
NETWORK=192.168.100.0
BROADCAST=192.168.100.255

VLAN_PLUS_VIDやVLAN_PLUS_VID_NO_PADを指定する場合、
[PHYSDEV]に物理NIC名(=eth1)を追加指定することがポイント。

[PR]
by mdesign21 | 2008-11-22 23:22 | Diary

スキル キャリア

言葉の定義を残しておきたく。

なので、...ψ(。。 )メモメモです(^^;

スキル=訓練して身に付けた技能。
キャリア=一連の職業上の活動や行為。職歴。

[PR]
by mdesign21 | 2008-11-15 07:15 | Diary

VMWareインフラリニューアル中間報告3

VMWareServer2.0 for Windows
■WindowsXPにインストできるけど、VMIC経由でのアクセスやブラウザからのWebAccessが不可
解決しました。

原因は、「VMWare Host Agentサービス」が予期せぬエラーで終了してしまう状態だっため。
しかも、「VMWare Host Agentサービス」を手動で起動しても、10秒程度で再度予期せぬエラーが発生。

なので、以下の方法を実施して解決。

1.まず、以下のファイルをtxtエディタで開く。

\Documents and Settings\All Users\Application Data\VMware\VMware Server\vm-list
(OSがインストールされているドライブに依存するので、ドライブ名は抜いて記載)

2.そうすると、以下のような表示が出てくる。

~・~・~・~・~・~・~・~・~・~・~・~・~・~・~・~・~・~・~・~・~・~
# This file is automatically generated.
# Hand-editing this file is not recommended.
config "E:\My Virtual Machines\WinSrv2003R2_Ent\WinSrv2003Ent.vmx"→こいつを削除
config "E:\My Virtual Machines\fc5\Other Linux 2.6.x kernel.vmx"→こいつも削除
~・~・~・~・~・~・~・~・~・~・~・~・~・~・~・~・~・~・~・~・~・~

3.そして「config~」が付いている行を全て削除。

4.その後、VMWare Host Agentサービスを起動しなおせばOKでした。

上記の削除した行はInventoryの情報なのかなぁ。
VMWareServer1.x系をアンインストール後に
VMWareServer2.0をインストールすると、
上記のゴミな行が残ってしまうみたい。
新規でVMWareServer2.0をインストールする分には発生しないはず。
(vm-listファイルの「#」以下には、何も記載されないから。)

タグ
VMWare Server 2.0 WebAccessできない
VMWare Server 2.0 起動できない
Windows XP
VMWare Host Agent
予期せぬエラー

[PR]
by mdesign21 | 2008-11-14 15:39 | Diary

NEの良いところ

ネットワークエンジニアの良いトコロ。

それは、

センスや感性、才能といったモノサシで、

差が出てくるのではなく、

自分がどれだけやったか?で、

差が出てくる仕事であるというトコロ。

だと、

オレは思ってる。

[PR]
by mdesign21 | 2008-11-12 23:50 | Diary

WindowsXP NFSサーバ ESXi NFSクライアント マウント

SFU3.5については、MSのサイトでDLしてください。

以下の順で設定すれば、ESXiからWindowsXPのNFSサービスに対して、
マウント&UL&DLできました。
昨日の予想は大外れでした。
詳細は明日以降にて。

DLスループット=110~120Mbps
ULスループット=90~100Mbps
蔵鯖共にGbEハブにて接続の構成

もう眠い、もう寝る。

1_ユーザ名マッピング_構成
e0113173_1262313.jpg


2_ユーザ名マッピング_マップ
e0113173_127528.jpg


3_nfs共有フォルダ_トップ
e0113173_1274294.jpg


4_nfs共有フォルダ_アクセス権
e0113173_128476.jpg


5_ESXi_NFS-Mount
e0113173_1283331.jpg

[PR]
by mdesign21 | 2008-11-11 01:30 | Diary

VMWareインフラリニューアル中間報告2

【ESXi】
■WindowsでNFSサービス稼動できるかな?

『SFU3.5』
http://technet.microsoft.com/ja-jp/interopmigration/bb380242.aspx
「Windows Services for UNIX 日本語版」のリンクをクリック
にて、NFSサーバ稼動OK&FileのULがOKでした。
以前のBlogに書いた以下のパターンがOKになりました。
 パターン2
 NFS鯖:WinXP with SFU3.5
 NFS蔵:ESXi
んで、どの当たりの設定が肝になっているか?ってところなんだけど、
今の段階では、正直わかりません(^^;
とっても緩々な設定にしたのは確かなんだけどねぇ。。
なので、地味なやり方だけど、今のWinXPの状態をTrueImageした後、
まっさらなWinXPをTrueImageで復元後、再度SFUをインストして、
その違いを切り分けて行きたいと考えてます。
恐らく、NFSサーバ>クライアントグループ設定画面にて、
「localhost」グループを追加する当たりかなぁと思ってますが。。
転送速度は概ね110~120Mbpsくらいです。一時的に30~40Mbpsに低下することがあります。
鯖蔵共にGbEハブに接続した状態で。
16.7GBのファイルULもOKでした。

『nfsAxe』
http://labf.com/nfsaxe/index.html
にて、NFSサーバ稼動OK&FileのULがOKでした。
ただし、nfsAxeはシェアウェアで、セッション開始してから30分で強制Umountされる(笑)
ちなみに、16.7GBのファイル転送を実施したんだけど、13.4GBくらいで30分経過してOut。
$40なんだけど、どう考えるか?だよなぁ。10GBくらいにしておけば。。。
転送速度は概ね140~150Mbpsくらいです。
鯖蔵共にGbEハブに接続した状態で。

『haneWIN NFS Server』
http://www.hanewin.net/nfs-e.htm
でも、NFSサーバ稼動OK&FileのULがOKでした。
ただ、転送速度が遅過ぎるため却下。
3Mbpsくらいなんだもん。


【VMWareServer2.0 x86_64 for Linux(以下、VMWS)】
■Phenom9350e(4core 2.0GHz)なのに、VM上では4core 1GHzと認識される。

1.以下のコマンドにて、VMWareのConfigファイルを編集
 vi /etc/vmware/config

2.以下の3行を最終行に追加

 host.cpukHz = "2000000"
 host.noTSC = "TRUE"
 ptsc.noTSC = "TRUE"


【VMWareServer2.0 for Windows】
については、前回より進捗なし。
タイムアップでした。土日だけだと時間が足りない。
加えて、会社支給PCのD430セットアップもあったから。
来週までお預けだねぇ(涙)

[PR]
by mdesign21 | 2008-11-10 01:54 | Diary